This is an adorable little kit that is a perfect introduction to wearable electronics. The heart of the kit
is the heart shaped electronics board with 8 LEDS. It is easy to program and requires no wiring. The
LEDs used are “smart” which means that it is easy to program all kinds of cool patterns from
rainbows to a beating heart.

Each Lovey Dove is pre-programed to light up in a single colour. To change the colour you will need
to download the Arduino IDE software, libraries, and drivers. Don’t worry if this sounds a bit
complicated we will walk you through the whole installation process.

What is included

e 1 Lovey Dove Board
o Micro-controller (Adafruit Trinket)
o 8 Neopixels (Special RGB LEDs)
e 1 Battery Pack (batteries not included)
USB Wire

Warning!

If your Trinket, Neopixel, or any part of your piece starts getting hot, unplug you the battery
pack immediately. Check your circuit for crossed wires. If this problem continues, contact
makerstore@uottawa.ca and we will help solve the problem.

Do not leave it plugged in for long periods of time unattended.

The soldered points on the underside of the heart pcb (little silver points) can be sharp. Be
careful when handling your piece.

Ressources:

o Neopixel guide:
https://learn.adafruit.com/adafruit-neopixel-uberguide/arduino-library?view=all

e Trinket guide:
https://learn.adafruit.com/adafruit-neopixel-uberguide/arduino-library?view=all
Windows trinket drivers: https://learn.adafruit.com/introducing-trinket/windows-setup
Installing the trinket:https://learn.adafruit.com/adafruit-arduino-ide-setup/overview
Arduino: https://www.arduino.cc/en/Main/Software
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Installation guide:

STEP 1: Installing the Arduino IDE

Click on https://www.arduino.cc/en/Main/Software and download the appropriate software. If you
run into any issues, arduino created handy guides which you can find at the following link:
https://www.arduino.cc/en/Guide/HomePage.

Download the Arduino IDE

Windows installer
Windows ZIP file for non admin install

ARDUINO 1.8.2 Windows app)| Get 2 |

The open-source Arduino Software (IDE) makes it easy to
write code and upload it to the board. It runs on
Windows, Mac OS X, and Linux. The environment is
written in Java and based on Processing and other open- 4
source software. Linux 32 bits
This software can be used with any Arduino board. Linux 64 bits
Refer to the Getting Started page for Installation Linux ARM
instructions.

Mac OS X107 Lion or newer

©.0,

Release Notes
Source Code
Checksumns (sha512)

STEP 2: Installing the trinket

1. Open the preferences window by click File>Preference. Paste
“https://adafruit.github.io/arduino-board-index/package_adafruit_index.json” into the
additional board manager then click ok. What you are doing is telling the arduino program
where to look to install the board.
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2. Next step is actually installing the board. Open the board manager by clicking Tools>Board:
>Boards Manager
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3. Anew window will appear. Next to type, there a a drop down menu, select Contributed.
Select Adafruit AVR Boards by Adafruit and click install.
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STEP 3: Install the Neopixel library.



1. Click on the following link http://github.com/adafruit/Adafruits_NeoPixel/archive/master.zip
and download the zip folder. Remember where you saved it.
2. Click on Sketch>Add ZIP Library...
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3. Select the zip folder that was just downloaded, Adafruit_NeoPixel-Master
STEP 4: Windows drivers
This step is only needed ONLY if you are running windows.

1. Click on the following link
https://github.com/adafruit/Adafruit_Windows_Drivers/releases/download/1.0.0.0/adafruit
drivers.exe and download the driver exe.
2. Runthe installer. Maker sure the Trinket option is selected before you click install.
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STEP 5: Installing ardublocks

If you are familiar with the Arduino IDE and plan on programming directly in arduino, you can stop
here. Ardublock are an easy puzzle style method of programming. Instead of typing out lines of code,
you simply connect the coloured pieces.

1. Go to the following link: http://makerepo.com/daniellet140/ardublocks. And download the
ArduBlockTool.zip file.

e __-a_a tr® ArduBlocks

v H -

Click directly on the file

ESCRIPTION



http://makerepo.com/daniellet140/ardublocks

2. Right click on the folder that you downloaded and select extract all. A new folder will be
created called ArduBlockTool. Inside there should be a folder called tool. Inside that folder
should be a file called ardublock-all.jar (or something similar).

Open

Open in new window

Extract All...

7-Zip >

CRC SHA > =
Pin to Start

% Move to Dropbox

D Scan with Windows Defender...
Open with...

Share with >

Restore previous versions

Cut
Copy

Create shortcut
Delete

Rename

Properties

ArduBlockToal

3. Now itis time to move the folder into your arduino folder and then tools.
a. WINDOWS: Your arduino folder is found in your program files. Open file explorer
and click on:
Windows(C:)->Program Files (x86) -> Arduino -> tools

Clipboard Crganise MNew COpen
v P * This PC > Windows (C) > Program Files (x86) » Arduino * tools v O Search tc

\/
sl Ll 2 A ST e S LH

b. MAC: Your arduino folder is found in the documents folder. Click on
Documents->Arduino->tools



Installation process COMPLETE
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Battery Pack On/Off switch

Sometimes the battery connector is hard to plug and unplug, so be gentle, but you may need to
apply some force.

There are TWO on off switches. One on the heart and one on the battery. For your heart to light up,
you need to have both switches in the on position.

What are neopixels

Neopixels are used to when you want to easily add lights and colours to your project.
Neopixels are a special kind of RGB LED that have an integrated driver board. An LED is a
light emitting diode, which means that when voltage is applied to the leads, it will light up.
RGB means that they can light up red, green, blue or a combination of the three. To get the
light up with the color you desire, you need to enter the right combination of red, green,
and blue. This is done by assigning each color a value between 0 and 255 where 0 is off and
255 is full brightness. If you input red=255, green=0, blue=0, then your LED will light up red.
If you want a magenta coloured light, enter red=255, green=0, blue=255.
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What is a trinket?

A trinket is a microcontroller which is like the brain of the computer. It is used to interpret and
execute the instructions we gave it. It takes the inputs and gives desired outputs which will depend
on the program we give it. In our case, everything is already wired and good to go. A wiring diagram
can be found ****** for those who are interested.

Programing in ArduBlocks

To open ArduBlocks, click on tools, located on the top menu bar, then ArduBlock. This option will
only be available if it was installed as shown earlier in the document.

: sEtch_purda | Ardung 142

Fidg Ecn Seetch Tools Hedg
Ao Format Carlald
Archive Selch

Fix Ercoading B Reload

Senal Mondtor Cirl+ Shift« M
Sefial Plothers Carl + Shift =1
Andulibock

o T B B E LR o L

Board: “Adafruit Trinket BAMHZ

Giet Board Info

Programmer; "USBtind s

Burn Bootloader

You will now have two windows, the green/blue one will be referred to as the arduino window, the
new window that just opened we will call the Ardublock window.
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Arduino window ArduBlock window

FIN
e MIMPIKELS
Adsfruit BecFficsl plosle-Adafriit Wsc@issl (NUMSINELS. FEN

- R 1

The grey area is where you will put your code. Think of it as your programming space. On the left
hand side there are many different types of blocks. We will focus mostly on Control and Heart PCB. If
you click on those buttons a menu will open and provide you with new puzzle pieces. If you want to
get rid of any pieces on your programing area, just click and drag your pieces back over to the menu
area.

] ArduBlock untitied - o X

New || seve || savess || Open || uploadtoArduino | | Serial Monitor

Programming
Area

Sove osimoge... || GotoWebSte | v 21040626 (beta)

The first step in programing our heart project is to click on the yellow loop in the programing area
and delete it. To do this, click on the piece and drag it over to the menu area. Next, click on the Heart
PCB and drag the loop with the picture of the heart into the programing area. This pieces has all the
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special background code needed to program our special lights. For more information on this code,
see the next section on programing directly in the Arduino IDE.

Next, go get the piece called “Pixel color between 0 and 255” and place it inside the yellow loop. If
hover over the piece attach to Neo_# hole, a drop down arrow will appear. Clicking on it will allow
you to select which LED you want to change. For this first example, | want to light up the 3rd light
blue. Therefore, | am going to select Neo_3 and change the color to blue.

Select which
LED you want
to light up

‘ Pick the colowr
yiou want

There is one last step need in our first code is to add the piece marked “Show pixels”. It can be found
under the Heart PCB menu This piece is important, it tell the neopixels to actually execute the task
you gave them. Without it, they will not light up.

Your code should look something like this:

weo # 7 HED 3

Colour Blue

Colour of one el

r

Sh_nw pixels
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Time to send the code to the heart. This is a little bit complicated, but once you get the hang of it,
you will become a heart programming pro.

Step 1: Go back to the arduino window. Click on Tools and bring your mouse over Board:. A list of
available boards will appear on the right hand side. Change the board to Board: “Adafruit Trinket
8MHz".
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Programmer ‘ i U

Step 2:In the tools menus, change the programer to Programmer: “USBtinyISP”.

Step 3: Now it is time to connect the heart chip to your computer. Plug in one end of the usb to the
heart PCB and the other to your computer.

Sometimes
the LED
naads to be
a little kit
bent
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Step 4: Now the hard part. Go back to the ArduBlock window and click upload Upload to arduino.
Simultaneously, press and release the reset button on the trinket (blue chip on heart). Two things
will be happening simultaneous.

In the arduino screen, the bottom line should say Compiling sketch, then Uploading..., and finally
Done uploading.

On the heart, a little red light should begin to pulse. The lights may also change colours. Make sure
that the red light is still pulsing when arduino says uploading. If you get the error shown in the
picture below, the red light was probably not flashing will it was uploading. If you computer is a little
bit sluggish, you may need to press the button a second time in order to make sure it remains
pulsing while uploading.

You know it has uploaded properly if the heart is doing what you programmed it to. In my case, only
the 3rd light should be lighting up and be blue.
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TROUBLESHOOTING

When you click upload, you get an angry looking error at the bottom of your arduino window

& sketch_jun01b | Arduino 1.8.2 — O e

-

File Edit Sketch Tools Help

sketch_jun01b

#define PIN 1
#define NUMPIXELS 8
Adafruit NeoPixel pixels=Adafruit NeoPixel (NUMPIXELS, PIN, NEO_RGB + NEO_KHZS8!

void setup()
{
pixels.begin(): //This initializes the NeoPixel library
for(int i=0;i<NUMPIXELS;i++) {
pixels.setPixelColor (i,pixels.Color(0,0,0)):
pixels.show();
delay(100);

void loop ()

pixels.setPixelColor (2, pixels.Color(0 ,0 ,255));
pixels.show():

avrdude: Errar: Could not find USBtiny device (0x1781/0xc9f)

Adafriit Trinkat AMH7 An COM3

If you error says avrdude: Error: Could not find USBtiny device (0x1781/0xc9f), it means that the
red light on the trinket board on your heart was probably not flashing when the arduino program
was trying to upload the code. Try again and release the button when you see the Compiling
message at the bottom of your screen. It may take some time to get it right. Check out this video ***
to see how | do it.
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redefinition of ‘void loop()'

Adafriit Trinkat AMH7 An COM3

If you get the error redefinition of ‘void loop()’ check to make sure that you actually got rid of that

BN

pesky original loop. Sometimes, it likes to hide behind the menu bar on the left

hand side.

Problem uploading to board. See http:/fwww arduino.cc/en/Guide/Troubleshaooting#upload for suggestions.

If you get an error that says Problem uploading to board. See
http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions. Check to make sure
that your board is set to Board: “Adafruit Trinket 8MHz” and programmer is Programmer:
“USBtinyISP”. These can be found in the arduino window, under the tools menu.
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More ArduBlocks

What if you want to change all the neopixels on your heart board? Fret not, there is a block for that.
Simply put the Colour of all pixels and then the Show pixels piece into the loop, as shown below.

Show pixels

Though we have several colours built in, you may want to try something of your own making. Delete
the block attached to the color hole and substitute it with Pixel colour between 0 and 255. By
changing the values connect to the Red Start, Green Start, Blue Start holes you can create your own
specialty colour.
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Show pixels

If you are interested in cool patterns, insert the pattern block and then the show pixel, as shown
below. This block will apply a pattern to all the pixels on the heart.

Pattern for

—_—

Sh-uw pixels

There are three things that you can change in the pattern block:

e Pattern: Let’s you pick the type of pattern you want to apply. You have the choice between
o Rainbow
o Rainbow cycle
O Theatre chase rainbow
o Theatre chase
o Color wipe
e Miliseconds: Change the pace of the pattern. A smaller number means that the pattern will
be faster.
e Theater chase: Is the starting color for certain patterns

The best way to get to know the patterns is to test them out.

Challenges!

Let’s test your programing skills. In this section we are going to play with some new blocks and some
new concepts.
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First let’s introduce the repeat loop which is found under the Control menu. This piece does exactly
what you would expect, it repeats the code placed inside it the number of times indicated.

|#| ArduBlock untitled * — m] ¥

L S Sawe AS Opes L 0 A g Serial Monior
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S ; Number of times
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LEER

[UR LA

seondsutocroe [N Where you will put

st T4 G s Al the- Cl:lde yDu Want

— to be repeated

Heail PCE

There is a similar block called repeat and count. This introduces two new concepts the first is a
“variable” and the second is a “counter”.

Thing we want
to count
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